Ati Ubuntu 7.10 (Gutsy) New (Catalyst 8.1)

Ниже представлен наиболее верный, с точки зрения идеологии Ubuntu, способ установки драйвера Catalyst 8.1 (возможно и более позднего) для видеокарт ATI с сайта производителя.

Официальный драйвер ATI присутствует в репозитории Ubuntu, но имеет некоторые нерешённые проблемы

Для начала нужно скачать Catalyst 8.1 с официального сайта или по прямой ссылке

Установка необходимой оснастки

  • Включаем компонент universe в /etc/apt/sources.list если он не включен
  • Устанавливаем необходимые инструменты
sudo apt-get update
sudo apt-get install module-assistant build-essential fakeroot dh-make debhelper debconf libstdc++5 linux-headers-$(uname -r)

Создаем .deb пакеты для нашей системы:

sh ati-driver-installer-8-01-x86.x86_64.run --buildpkg $(lsb_release -si)/$(lsb_release -sc)

Теперь устанавливаем .deb пакеты:
(на вопрос о замене файла /etc/xdg/compiz/compiz-manager отвечаем утвердительно "Y")

sudo dpkg -i xorg-driver-fglrx*.deb fglrx-kernel-source*.deb fglrx-amdcccle*.deb
sudo apt-get install -f

Включаем драйвер

sudo aticonfig --initial --force

Перезагружаемся и проверяем

$ fglrxinfo

display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 2400 PRO
OpenGL version string: 2.1.7276 Release

Примечания

Использование двух мониторов на одной видеокарте (dualhead)

  • вместо sudo aticonfig --initial --force пишем (пример для горизонтального расположения мониторов):
sudo aticonfig --initial=dual-head --dtop=horizontal --force

Включаем Overlay (если нужно)

sudo aticonfig --overlay-on=1

PS: Проверено на Ubuntu Gutsy (7.10), direct rendering, compiz и composite работают

Unless otherwise stated, the content of this page is licensed under Creative Commons Attribution-ShareAlike 3.0 License